您当前的位置: 首页 > 技术文章 > 前端开发

解决npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.

作者: 时间:2022-06-12阅读数:人阅读

使用npm时,报错:npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.

我找到了一篇帖子,他是对的,怕那个提问帖子过期,我抄下来了。如下:

将npm升级到最新版本即可
升级方法
1.在windows中以管理员身份打开cmd,然后执行命令
npm install -g npm-windows-upgrade
2.更改脚本策略
下载Windows Power Shell
然后以管理员身份运行,执行命令
set-ExecutionPolicy RemoteSigned

解决npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead.(图1)


输入Y
成功更改脚本策略
3.在Windows Power Shell上运行命令
npm-windows-upgrade

问题解决!

其实此问题是由版本号导致
问题解决链接:
[BUG] `npm.cmd` uses deprecated switch `-g` · Issue #4980 · npm/cli · GitHub
解决:无法加载文件 C:\Users\user\AppData\Roaming\npm\npx.ps1,因为在此系统上禁止运行脚本 。_songywaa的博客-CSDN博客

 

本站所有文章、数据、图片均来自互联网,一切版权均归源网站或源作者所有。

如果侵犯了你的权益请来信告知我们删除。邮箱:licqi@yunshuaiweb.com

标签: npm 前端
加载中~
如果您对我们的成果表示认同并且觉得对你有所帮助可以给我们捐赠。您的帮助是对我们最大的支持和动力!
捐赠我们
扫码支持 扫码支持
扫码捐赠,你说多少就多少
2
5
10
20
50
自定义
您当前余额:元
支付宝
微信
余额

打开支付宝扫一扫,即可进行扫码捐赠哦

打开微信扫一扫,即可进行扫码捐赠哦

打开QQ钱包扫一扫,即可进行扫码捐赠哦

天猫38节现货-全屋智能