您当前的位置: 首页 > 技术文章 > 前端开发

Node.js16.15.1的一个报错及解决方案

作者: 时间:2022-06-14阅读数:人阅读

Node.js16.15.1的一个报错及解决方案

前言

最近在进行Node.js的下载安装和环境的配置,在官网上下载了LTS版本16.15.1,没想到在后续的使用中出现一种报错。

例如,在命令提示符窗口中输入npm -v 想要查看npm的版本号:

在这里插入图片描述

npm WARN config global `--global`, `--local` are deprecated. Use `--location=global` instead

关于这个报错,我一开始的解决方案是将Node.js安装目录下的npm.cmd文件第12行的prefix -g 改成prefix --location=global,之后再在命令提示框中输入npm -v确实不报错了,我就以为解决了,没想到有小伙伴反映git bash中运行仍会报错,我在命令提示符窗口测试的时候输入npm install express -g 发现确实问题没有完全解决。(如果你按之前的方案把npm.cmd文件改了,建议还是先改回来吧······)

在查找解决方案的时候,我发现最新版本的npm已经发布了一个补丁来删除这条弃用警告(详情见https://github.com/npm/statusboard/issues/518),也就是说在你所安装的 node 版本和最新版 npm 兼容的前提下我们升级到最新版的npm就可以解决问题了。于是我兴冲冲地踩了又一个坑,就是直接在命令提示框输入npm install -g npm 。但其实,在 Windows 上升级 npm 需要手动步骤以确保 PowerShell/CMD 找到新版本的 npm 。(感谢这个帖子的一个评论帮助我定位了问题:https://stackoverflow.com/questions/72401421/npm-warn-config-global-global-local-are-deprecated-use-location-glo/72477810#72477810

准备工作

开始之前有两个问题要注意:
一是必须先完成环境变量的配置,否则后面会出现类似这种报错:

npm-windows-upgrade : 无法将“npm-windows-upgrade”项识别为 cmdlet、函数、脚本文件或可运行程序的名称。请检查名称的拼写,如果包括路径,请确保路径正确,然后再试一次。
所在位置 行:1 字符: 1
+ npm-windows-upgrade
+ ~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : ObjectNotFound: (npm-windows-upgrade:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

二是可能你的node.js安装文件夹存在权限问题,后续可能出现类似这种报错:

Error: EPERM: operation not permitted, open 'D:\Program Files\nodejs\node_global\_logs\2022-06-11T18_14_51_227Z-debug-0.log'
npm WARN logfile could not be created: Error: EPERM: operation not permitted, open 'D:\Program Files\nodejs\node_global\_logs\2022-06-11T18_14_52_917Z-debug-0.log'

以防万一,建议还是先将权限打开(如果你的当前用户是管理员可以略过下面添加权限的步骤):

1、打开安装文件夹所在根目录,我的是在D盘,右键点击安装文件夹,点击“属性”:在这里插入图片描述

2、点击“安全”,选择编辑:
在这里插入图片描述

3、点击该用户,我嫌麻烦,就直接勾选下方的“完全控制”:
在这里插入图片描述

4、点击“应用”后点击“确定”:
在这里插入图片描述

5、再点击“确定”退出:
在这里插入图片描述

核心解决方案

准备工作做完后,核心解决方案如下:

首先,在桌面任务栏的搜索框内输入“cmd”,点击“以管理员身份运行”,以免后续操作权限不足导致操作失败:

在这里插入图片描述

然后,在命令提示符窗口输入npm install -g npm-windows-upgrade

在这里插入图片描述

关闭窗口后,找到Windows PoweShell,右键,点击“以管理员身份运行”:

在这里插入图片描述

接着在PowerShell中输入set-ExecutionPolicy RemoteSigned ,按下回车后会显示是否要更改执行策略的选项;我们输入Y 后按下回车;接着输入npm-windows-upgrade ;接着会显示各个版本,用方向键 加以选择,不过默认是最高的8.12.1,就直接按回车就好了。稍等片刻,就完成更新了:

在这里插入图片描述

测试

我们在命令提示框中输入npm -v,可以看到,即使没更改npm.cmd文件,也不会报错了:

在这里插入图片描述

接着我又输入了npm install express -g 进行测试,仍然不会报错。

至此,该问题已解决。

本站所有文章、数据、图片均来自互联网,一切版权均归源网站或源作者所有。

如果侵犯了你的权益请来信告知我们删除。邮箱:licqi@yunshuaiweb.com

标签: node.js npm
加载中~
如果您对我们的成果表示认同并且觉得对你有所帮助可以给我们捐赠。您的帮助是对我们最大的支持和动力!
捐赠我们
扫码支持 扫码支持
扫码捐赠,你说多少就多少
2
5
10
20
50
自定义
您当前余额:元
支付宝
微信
余额

打开支付宝扫一扫,即可进行扫码捐赠哦

打开微信扫一扫,即可进行扫码捐赠哦

打开QQ钱包扫一扫,即可进行扫码捐赠哦

天猫38节现货-全屋智能